5 posts / 0 new
Last post
admin's picture
Offline
Last seen: 16 hours 2 min ago
Joined: 04/09/2013 - 14:19
Posts: 51595
Systemdek IIX problem....

So I am playing the record player game a lot at the moment...

I have just got in a Rega Planar 2 but unfortunately it has a cartridge issue so I will not be able to play with that....

I managed to get a Systemdek IIX for cheap with an RB250 and a Linn K9.  It put my SME Thorens to shame  Sad .... producing clearer and more exciting music, however it has to go (I am assuming that the Thorens might need a different cart - Goldring 1042 - or arm adjustment in order to get the best from it) as I do not like lifting the platter every 5 mins to switch from 33 to 45...

Now to the problem....

The deck seems to play 33 fine, when I switch it 45 though it the belt seems to drop off easily or switch back to 33.

At first I thought... hmmm new belt.  Which arrived today.  However no change.

I obviously discovered that you need to put the platter back on to normalise the the height of the platter bearing with the motor... however even once I discovered this it still sometimes struggles (I would say one third of the time).

Is this just s Systemdek?  What is going on here?  It makes it difficult to sell if I cannot be confident that it is how it should be.

 

John Duncan's picture
Online
Last seen: 13 min ago
Joined: 08/01/2008 - 17:25
Posts: 23023
Re: Systemdek IIX problem....


Weird one this. The motor on the deck is fixed to the plinth, while the suspended chassis rides up and down - therefore meaning that the subplatter can move up and down relative to the motor pulley. The height of the subplatter (with the platter on) therefore needs to be *just right* for it to work properly on both the 33 and 45 levels of the platter. Course, adjusting those three bolts for the subchassis requires you to have the platter off (bummer), so it's total guesswork.

Trying to imagine how the belt is falling off, it suggests the platter is riding too high and you need to lower it a few mill - which if I recall is anticlockwise turns of the bolts, but do check. Do one turn at a time on each bolt (to maintain current delicate balance), try again, repeat until it works ok on both 33 and 45.

Moderator: john.duncan.whf at gmail dot com

chebby's picture
Offline
Last seen: 16 hours 49 min ago
Joined: 02/06/2008 - 09:40
Posts: 16006
Re: Systemdek IIX problem....

Is the motor pulley height adjustable? (Small grub screw or similar?)

"We are currently awaiting the loading of our complement of small lemon-soaked paper napkins for your comfort, refreshment and hygiene during the journey."

John Duncan's picture
Online
Last seen: 13 min ago
Joined: 08/01/2008 - 17:25
Posts: 23023
Re: Systemdek IIX problem....


jeez, I hope not, otherwise that was four hours of my life I wasted...

Moderator: john.duncan.whf at gmail dot com

Anonymous
Anonymous's picture
Re: Systemdek IIX problem....

Are the rubber mounts that the motor is supported in old and soft, or even starting to disintergrate?

Log in or register to post comments