4 posts / 0 new
Last post
lxd55's picture
Offline
Last seen: 1 week 4 days ago
Joined: 24/01/2009 - 13:10
Posts: 112
Marantz NA7004 Firmware issue

Looks like I have a serious prob with my NA7004, clocked a new firmware update yesterday and kicked it off. But it doesn't complete, stops with a error code 3A. Only way to restart is to remove the power, which they state you shouldn't do, but nothing works once it fails so have no option.

Once power re-applied it starts to download automatically from 14mins to go, but stops short at different times (9, 6, 2 mins) with the same error code,3A???

 

i tried the micro reset from the user manual (page 28), but the system keeps going to the same download start from 14mins.

 

fearing the firmware is corrupted, anyone else had issues before I contact marantz??

 

appreciate any feedback, even if to confirm updated the firmware ok.

 

kr

 

lxd55

Anonymous
Anonymous's picture
RE: Marantz NA7004 Firmware issue

Having the same issue here. Puled the plug also then pressed Display + M-DAX while plugging in the power, waited some seconds (3 lights burn left in display), released the buttons and i got it working again. I have then tried to update it once more with no luck (right now).... :quest:

lxd55's picture
Offline
Last seen: 1 week 4 days ago
Joined: 24/01/2009 - 13:10
Posts: 112
RE: Marantz NA7004 Firmware issue

Hi Edwin,

thanks for reply. Will try the reset again (maybe I didn't hold the buttons long enough??)

have posted to marantz support for feedback. Will update if I hear anything.

 

 

lxd55's picture
Offline
Last seen: 1 week 4 days ago
Joined: 24/01/2009 - 13:10
Posts: 112
RE: Marantz NA7004 Firmware issue

Update to post:


Posted to marantz support. They sent instructions to factory reset the player. Interestingly these differ from the online manual?


In the manual tells you to hold the display & m-dax buttons.


In the email marantz sent me told me to hold cursor down and m-dax




This reset the player. Then it asked to update the firmware, which it did with no issues, so looks like I'm good to go again. Not sure on the specifics of the update, though AirPlay seems to be working- it had suddenly failed to show itself for a few weeks (not sure why?)




Giving the killers new album from spotify a blast via AirPlay to check it works reliably, so far so good and the albums pretty good as well Smile




Kr


Lxd55

Log in or register to post comments