11 posts / 0 new
Last post
admin's picture
Offline
Last seen: 15 hours 23 min ago
Joined: 04/09/2013 - 14:19
Posts: 51595
Pure i-20 dock, Cracking and Popping!

just plugged in my new i-20 digital dock and disapointed to find a slight popping or cracking auidible during the quieter parts of various tunes. Only seems to happen when playing using my iPhone 4, my iPod classic plays without any problems at all. I'm using the analogue outputs and have tried the phone in airplane mode but it made no difference. Anybody come across and hopefully solved the same problem? Thanks, Dave.........

Andy Clough's picture
Offline
Last seen: 13 hours 14 min ago
Joined: 27/04/2004 - 16:13
Posts: 6667
RE: MP3/MP4

Not encountered the problem with my iPhone 3G S or Touch. A couple of the guys at work have iPhone 4s, so I'll check with them tomorrow.

Editor-in-Chief of What Hi-Fi? Sound and Vision and whathifi.com

Anonymous
Anonymous's picture
RE: MP3/MP4

Thanks Andy,
I look fwd to yor response. It may find its way back to the shop which would be a shame as it sounds great otherwise.

Just added my wifes touch to the list of iPods it works fine with, seem its my i4 that it doesn't like

Cheers, Dave.........

Anonymous
Anonymous's picture
RE: MP3/MP4

Just got my i-20 and I'm having exactly the same issue!  I tried it first with Spotify and thought it was fine, then I played some stored music and the popping noise was evident immediately. I then went back to listening to Spotify and it was there too, though only very slight. I'm using an iPod Touch 4th Gen. I have to say I'm a bit gutted as I was looking forward to getting the i-20. Cry

Dave, have you solved the issue yet or been in contact with Pure?

Andy Clough's picture
Offline
Last seen: 13 hours 14 min ago
Joined: 27/04/2004 - 16:13
Posts: 6667
RE: MP3/MP4

Checked with the test team and this is not a problem we've encountered with either iPhone 4 or 3G S. I'd give Pure a call and see what they say: 01923 260511.

Editor-in-Chief of What Hi-Fi? Sound and Vision and whathifi.com

Anonymous
Anonymous's picture
RE: I contacted Pure via their MP3/MP4

I contacted Pure via their website and got a reply today, they agreed its sounds like a problem and asked me to return it. I opted to return to the online retailer (not sure if I can mention the name but think of rain forests). Pretty good service from Pure though, they offered to send the replacement without waiting for the returned unit. Hopefully the replacement will be here in a couple of days and I'll let you know how I get on.

Anonymous
Anonymous's picture
RE: MP3/MP4

The replacement arrived today and has exactly same problem, classic and touch play fine, stick my iPhone on and it pops and crackles like a dirty vinyl record of old.

I guess it could be related to my iPhone but it works fine with my old analogue dock. I cleaned out the dust from the socket on the phone but it made no difference.

will return for a refund and resort back to my old dock slightly frustrated.

Anonymous
Anonymous's picture
RE: MP3/MP4

Hi Dave, I left the i-20 on overnight (ipod not attached) went to work the next day, came home and tried using it again and hey presto, it worked fine! Not a pop or crackle to be heard. I did nothing different apart from leaving the power lead attached to the dock. I re-checked it again this morning and it's still fine. I can't think of any reason why this problem should suddenly go away. Maybe the DAC components needed some 'burn in' time, or maybe it's sensitive to interference from the mains supply or other components?
And I have to say I'm really impressed with the sound quality on 320kbps Spotify and also with the same bitrate stored files. Let's hope that the popping noises stay away!

Anonymous
Anonymous's picture
RE: MP3/MP4

I reported the problems with the replacement to Pure again and was advised to power cycle (turn on and off) my iPhone and try again, I can't remember the last time i actually turned it off.

 

This appears to have solved the problem, been listening for a couple of hours with no pop's or crackles so very happy at the moment. Fingers crossed that they don't come back or that I have to reset my iPhone everyday. Goes to show that the old problem solving method of turn it off and on again still holds true.

 

Thanks for your suggestions and comments.

Anonymous
Anonymous's picture
RE: MP3/MP4

Hi sorry to be a pain , I have just got a pure i-20 to connect to a Marantz cr601 with an Ipod touch 64gb model , I am also getting the popping sound , when you mention resetting your Ipod do you mean turning it fully off and back on ? Thanks for any help on this .

Anonymous
Anonymous's picture
RE: MP3/MP4

Yes, exactly that. Just switch the iPod fully off and then on again and the popping noises should stop. I had the same issue a few months back when I got my i20 and it has re-occured a couple of times since then but the 'cure all' switch it off then on again fixes the problem.

Log in or register to post comments