4 posts / 0 new
Last post
admin's picture
Offline
Last seen: 9 hours 38 min ago
Joined: 04/09/2013 - 14:19
Posts: 51602
speaker issue
English

Hi everyone.

I have a pair of intimidation XS-6 powered monitor speakers and this morning there was only treble coming from one speaker no bass or mids
the other speaker is fine, I have tried multiple sources but no joy:(. I know I'll have to send it in for repair but does anyone know what could be wrong?

The speakers have never stressed or pushed in any way.

bearwolfblade's picture
Offline
Last seen: 11 months 3 weeks ago
Joined: 04/07/2011 - 17:28
Posts: 69
RE: speaker issue

If you've checked the wiring and swapped the L/R channels. then its a repair job im afraid

Mr. Iceman's picture
Offline
Last seen: 4 months 1 week ago
Joined: 29/11/2008 - 10:11
Posts: 162
RE: speaker issue

These being active (or powered?) they probably have some switches and pots in the back. Try moving/turning those and see if anything happens. If not, and after you've checked the cabling, I hope they are still covered by warranty. 

Overdose's picture
Offline
Last seen: 1 week 1 day ago
Joined: 08/02/2008 - 18:23
Posts: 3669
RE: speaker issue

For fault finding, the following will help determine the fault...

Wiggle connections at all points when the music is playing, a loose connection will show up if it's there.

Operate switches and controls when the speaker is in operation.

Swap connections between left and right channel inputs, if the fault transfers the problem is not the speakers, if it remains on the original channel it is the speaker.

If the speakers are out of warranty, turn off the power and disconnect, remove the back panel and see if there are any loose/broken wires.

Look for any obvious damage to the internal components.

At this point, if you have found nothing obvious, you might want to seek some more professional help.

Log in or register to post comments