7 posts / 0 new
Last post
Dan Turner's picture
Offline
Last seen: 6 months 1 week ago
Joined: 09/07/2007 - 22:50
Posts: 1012
Sonos music library behaving oddly...now fixed
English

Hi,

 

I was wondering if any Sonos users out there had any thoughts on this issue.

 

I was using Sonos when i realised that I couldn't see an artist I was expecting in my music library, then upon further inspection i realised that some others were missing, and also that the ordering seemed a little jumbled wth artists from one letter of the alphabet spilling over into the section for the next/previous letter. This was on the Mac controller, so I checked my iPhone and if anything it looked even more jumbled on there, with things being downright out of order.

I tried quitting/re-starting which didn't make any difference, and I am currently re-indexing the library, which so far seems to have run much longer than normal (about 25 mins and counting). Also, I've got my indexing scheduled for 04:30 daily, so if it was a problem with the index I'm not sure what could have happened between 04:30 and 10:00 when I first noticed this issue.

Sonos is pointing at my iTunes library stored on my NAS - I've verified that everything looks fine with that, and also that Sonos is pointed to the right place. Everything looks fine in iTunes too, so t really doesn't look like there's a problem at the NAS end. Also playing back something that which is present in Sonos works fine.

 

It's very peculiar - any thoughts?

 

Thanks

Dan

scene's picture
Offline
Last seen: 3 weeks 18 hours ago
Joined: 25/09/2008 - 12:48
Posts: 2977
RE: Sonos music library behaving oddly...

Have you updated your iTunes software recently - if so, check you're using the latest Sonos software.

And, just a thought - have you embedded artwork in your music using any third-party software?

Dan Turner's picture
Offline
Last seen: 6 months 1 week ago
Joined: 09/07/2007 - 22:50
Posts: 1012
RE: Sonos music library behaving oddly...

Hi Scene - thanks for the reply.  I'm using the latest Sonos and the latest iTunes software.  I have used a combination of the a script downloaded from the Sonos support site to embed artwork in bulk, and individually pasting the artwork in to the artwork box in iTunes - the library has been working fine like this for years and I haven't added any new albums or done anything with the metadata since log before this issue started.

 

Indexing is still running  :?

Dan Turner's picture
Offline
Last seen: 6 months 1 week ago
Joined: 09/07/2007 - 22:50
Posts: 1012
RE: Sonos music library behaving oddly...

OK - managed to fix it -  I had to reset the controller on both Mac and iPhone (after checking, iPad, CR100 and CR200 didn't seem to be affected).

 

Next time i'll try a controller reset first, but I didn't think that would do anything that a quit/restart couldn't!

scene's picture
Offline
Last seen: 3 weeks 18 hours ago
Joined: 25/09/2008 - 12:48
Posts: 2977
RE: Sonos music library behaving oddly...

Are you using iTunes 11.0, or 11.0.1?

Also, are you using iTunes Match - if make sure it is unticked...

And, it might be worth while making sure that you're not in iTunes if re-indexing.

Dan Turner's picture
Offline
Last seen: 6 months 1 week ago
Joined: 09/07/2007 - 22:50
Posts: 1012
RE: Sonos music library behaving oddly...

Thanks Scene.  As above I've resolved it now.

scene's picture
Offline
Last seen: 3 weeks 18 hours ago
Joined: 25/09/2008 - 12:48
Posts: 2977
RE: Sonos music library behaving oddly...

Dan Turner wrote:

Thanks Scene.  As above I've resolved it now.

OK - glad to hear.

Strange - swear your post wasn't visible when I posted mine...

Log in or register to post comments