7 posts / 0 new
Last post
admin's picture
Offline
Last seen: 9 hours 8 min ago
Joined: 04/09/2013 - 14:19
Posts: 51601
No Bass - Speaker broken?
English

Hello, I am after a bit of advice here.

The bass cone of my speakers (Acoustic Energy AE1) is not working i.e. no Bass from one of the speakers.

I have checked all of the connections and have connected the speaker to the other channel of the Amp and have confirmed that it is defeinately the speaker with the problem. I have had a good look inside the cabinet and have not noticed any obvioulsy loose connections.

It is only the bass cone which is not working, tweeter is fine. Is it likely that the bass cone has blown?

 Any ideas anyone? Does this soun like a repair/replacement job? It's a bad time for this to happen to me as I havce just forked out for the Marantz CD player and was planning on saving up for some good speakers like MA RS1s, Epos or B&W about £350 mark and was going to rely on the Aegis 1 until then? Any advice greatly appreciated

Andrew Everard's picture
Offline
Last seen: 1 year 3 weeks ago
Joined: 30/05/2007 - 12:34
Posts: 28836
Re: No Bass - Speaker broken?

Takes quite a lot to blow a bass unit - treble units are much easier Smile

It could be a component in the crossover that's failed, which you could check by touching the ends of your speaker cable directly to the terminals on the bass unit - with the amp at very low volume. just in case.

That should establish whether the drive unit is gone, or the problem is elsewhere.

But either way it sounds like a repair/replace job.

Anonymous
Anonymous's picture
Re: No Bass - Speaker broken?

If you have blown your woofer, then AE will probably offer them for sale as a replacement. Give the cone a gentle push in, does it give a load of resistance? Compare with your known-working speaker. While that'll mean it's blown, it not being stiff doesn't mean it hasn't.

Anonymous
Anonymous's picture
Re: No Bass - Speaker broken?

Did as you said Andrew and there was no response so must be the bass unit. I will contact AE today about replacement units or it might be new speakers.

Many Thanks

Anonymous
Anonymous's picture
Re: No Bass - Speaker broken?

Hi Mr P,

Did as you said and found that the broken bass unit (see post above) offered slightly less resistence than the working one, but only slightly. As said above I will contact AE today.

Many Thanks

Anonymous
Anonymous's picture
Re: No Bass - Speaker broken?

The speaker can be easily tested with a 1.5V battery although every home should have a cheap multimeter. (imo)

 

Regards Ed 

Anonymous
Anonymous's picture
Re: No Bass - Speaker broken?

It is definately the bass unit that has gone - rang Monitor Audio and it's about £40 (in. VAT and delivery) for new bass unit. Don't think I could get that much on ebay form the speakers if they were in working order. Hmm think it's time for some new ones.
Thinking about getting the BR2s - I was going to save up and spend more but figure these will keep their 2nd hand value quite high until I've saved another £200 or so.

Cheers for the advice.

Log in or register to post comments