14 posts / 0 new
Last post
jcarruthers's picture
Offline
Last seen: 2 years 5 months ago
Joined: 29/01/2013 - 21:04
Posts: 225
New Rega RP3 — no sound on right channel

Hi all,

 

So I got a new RP3 and set it up as per the instructions — first time I've done it.

Obviously the shop I bought it from is closed right now so I thought I'd ask on here.

There's no right channel at all and the sound from the left just doesn't sound right.

If I plug in only the right channel in I just get a load of humming with a very feint sound of the music.

 

James

 

jcarruthers's picture
Offline
Last seen: 2 years 5 months ago
Joined: 29/01/2013 - 21:04
Posts: 225
RE: New Rega RP3 — no sound on right channel

I got my multimeter out and there's continuity on the right channel phono plug Sad

 

plastic penguin's picture
Offline
Last seen: 5 hours 27 min ago
Joined: 28/04/2008 - 10:56
Posts: 18653
RE: New Rega RP3 — no sound on right channel

Take it back - they'll replace it...

 

Leema Pulse; Arcam CD73; PMC TB2i; Pro-ject Xpression with a ClearAudio cart; Denon TU260 MKII

stevebrock's picture
Offline
Last seen: 4 days 22 hours ago
Joined: 13/11/2009 - 11:16
Posts: 4542
RE: New Rega RP3 — no sound on right channel

What a shame, please stick with it!

The RP3 is a great TT what cartridge did you go for?

 

Black Gyro SE / SME IV / Rega Aria / AT33 PTG II / Elicit R / ATC SCM11

 

 

jcarruthers's picture
Offline
Last seen: 2 years 5 months ago
Joined: 29/01/2013 - 21:04
Posts: 225
RE: New Rega RP3 — no sound on right channel

plastic penguin wrote:

Take it back - they'll replace it...

 

 

No worries about that — just a mild pain as I bought it in central London and lugged it home on the train.

Was hoping it might be an easy fix.

 

 

jcarruthers's picture
Offline
Last seen: 2 years 5 months ago
Joined: 29/01/2013 - 21:04
Posts: 225
RE: New Rega RP3 — no sound on right channel

stevebrock wrote:

What a shame, please stick with it!

The RP3 is a great TT what cartridge did you go for?

 

 

Went for the Elys 2.

Feeling a bit knocked back as it sounds awful right now Sad

 

stevebrock's picture
Offline
Last seen: 4 days 22 hours ago
Joined: 13/11/2009 - 11:16
Posts: 4542
RE: New Rega RP3 — no sound on right channel

grrrr what a pain!

I hope you get it sorted soon, I gather you have discounted the amp at fault?

The Elys 2 is a fine cartridge, in all honesty I think I will get another when mine is worn out!

 

Black Gyro SE / SME IV / Rega Aria / AT33 PTG II / Elicit R / ATC SCM11

 

 

jcarruthers's picture
Offline
Last seen: 2 years 5 months ago
Joined: 29/01/2013 - 21:04
Posts: 225
RE: New Rega RP3 — no sound on right channel

stevebrock wrote:

grrrr what a pain!

I hope you get it sorted soon, I gather you have discounted the amp at fault?

The Elys 2 is a fine cartridge, in all honesty I think I will get another when mine is worn out!

 

Yep — was working fine with the Pro-Ject beforehand — and swapping the left and right around does as expected.

The multimeter is showing there is a fault — so no need to think about the amp.

 

stevebrock's picture
Offline
Last seen: 4 days 22 hours ago
Joined: 13/11/2009 - 11:16
Posts: 4542
RE: New Rega RP3 — no sound on right channel

Any joy with your RP3? Have you got a replacement?

 

Black Gyro SE / SME IV / Rega Aria / AT33 PTG II / Elicit R / ATC SCM11

 

 

jcarruthers's picture
Offline
Last seen: 2 years 5 months ago
Joined: 29/01/2013 - 21:04
Posts: 225
RE: New Rega RP3 — no sound on right channel

The dealer is sending me a replacement cartridge — easy peasy.

 

jcarruthers's picture
Offline
Last seen: 2 years 5 months ago
Joined: 29/01/2013 - 21:04
Posts: 225
RE: New Rega RP3 — no sound on right channel

Poor thing.

http://www.flickr.com/photos/jamescarruthers/8681899470/in/photostream/lightbox/

stevebrock's picture
Offline
Last seen: 4 days 22 hours ago
Joined: 13/11/2009 - 11:16
Posts: 4542
RE: New Rega RP3 — no sound on right channel

the best colour too!

Love my white RP3

 

Black Gyro SE / SME IV / Rega Aria / AT33 PTG II / Elicit R / ATC SCM11

 

 

jcarruthers's picture
Offline
Last seen: 2 years 5 months ago
Joined: 29/01/2013 - 21:04
Posts: 225
RE: New Rega RP3 — no sound on right channel

Finally all sorted—

Now to bed the cartridge in— happy to listen to vinyl after two weeks—

Hi-FiOutlaw's picture
Offline
Last seen: 4 hours 8 min ago
Joined: 20/04/2011 - 23:03
Posts: 2492
RE: New Rega RP3 — no sound on right channel

jcarruthers wrote:

Finally all sorted—

Now to bed the cartridge in— happy to listen to vinyl after two weeks—

 

Enjoy IT!!! 

I can not imagine myself at this pont two week withouth listening to vinyl.... 

 

Best REGArds 

:cheers:

Rega RP6/Goldring Elite>Clearaudio Basic Plus

Synology NAS>Rega DAC>Pathos Classic One MKIII>Dynaudio Excite X12

Log in or register to post comments