Have your say & ask the experts!

Problems with setting static IP address

47 replies [Last post]
Chisy1's picture
Offline
Joined: 13 Aug 2008
Posts: 222

I'm trying to create a static IP address for my iMac running OSX 10.6 to connect to my free router from my ISP (Thomson-Alcatel TG585vcool so that I can then portforward to try to access Bonjour via wifi (so iTunes can see my Synology NAS).  I followed all the instructions on this website (suggested by my ISP) http://portforward.com/networking/static-Mac10.4.htm which are very straightforward but when I then try to log into the internet I get a message saying I'm not connected.  Running network diagnostics doesn't help and as soon as I revert back to DHCP my internet connection reappears.  I spoke to the technical support of my ISP but they confirmed I was not dropping my broadband connection when trying to use the static IP.  I tried around 10 static IP addresses but none of them worked.

Has anybody else had this problem?  Is it because I am using an Airport Express (802.11g) to create the wireless network rather than the router itself?

 

If I can't get this fixed then I will have to resort to a homeplug to effectively connect my iMac to the router so iTunes then 'talks' to the NAS.   Can anyone recommend some reasonably priced homeplugs that work well (sub £100).

 

 

The_Lhc's picture
Online
Joined: 16 Oct 2008
Posts: 12582
RE: Problems with setting static IP address

I think you'll have to tell the Router you want a static IP address, rather than just setting one on your Mac. Depending on the router you can possibly still use DHCP, you just tell the router you want the same address for that device (ie your Mac). So your Mac will still use DHCP to request an address, it'll just be given the same address every time, rather than a random one. What you're doing at the moment is forcing your Mac onto a different address from the one that your Router has assigned to it, which is why you're dropping your internet connection (you're not actually connected to the Router).

Incidentally, I don't know what Bonjour is but are you attempting to access your iTunes from outside your network (ie from an external device via your Broadband connection)? In that case it's possibly your external internet IP address that needs to be static, not the one on your Mac. That'll depend on your ISP, some give them (mine does) but most don't, generally speaking.

Chisy1's picture
Offline
Joined: 13 Aug 2008
Posts: 222
RE: Problems with setting static IP address

Thanks The_LHC.

I will need to try to figure out how to ask the router to do this - might just be easier to get those homeplugs!!

There was an option in Network configurations in OSX which from memory said something like "DHCP with manual address", but I suspect that is something different.

 

I'm not trying to get access outside of home - just having problems with iTunes recognising my NAS wirelessly...it will do if imac also connected to the router by ethernet.

 

Much obliged

Chisy

 

ps - Not sure how I managed to put a pair of sunglasses on my first post either, certainly not deliberate   doh! !

AnotherJoe's picture
Offline
Joined: 10 Jun 2011
Posts: 783
RE: Problems with setting static IP address

*With port forwarding - if you use the devices network name rather than its ipaddress you dont need static ips.

 

However if you want static ips....

When your routers internet connection is working - on its config page make a note of subnet mask ( probably 255.255.255.0 ) and the DNS Gateway.

 

Turn off DHCP on the router.

Manually add the ip address of the router eg ( 192.168.0.1 ), the subnetmask, and the DNS Gateway from before. Save.

 

Then you can enter static ip addresses for each of your devices on your network - making sure each one is unique. For each device on the network the default gateway is the ip address of the router. subnet mask as above.

 

 

__________________

Server Synology 12Bay DS2413+, Synology 8Bay DS1812+, Sky+HD 

Lounge Samsung UE55D9000, Denon DBT-3313, Onkyo TX-NR5009, Tannoy Arena Highline 500 LCR, ACRyan playon!HD mini2 

Reception Samsung UE46C8000, Panasonic BDP310, Sony STR-DA5400ES, KEF2005.3, ACRyan playon!HD mini2 

The_Lhc's picture
Online
Joined: 16 Oct 2008
Posts: 12582
RE: Problems with setting static IP address

Chisy1 wrote:

Thanks The_LHC.

I will need to try to figure out how to ask the router to do this - might just be easier to get those homeplugs!!

I'm not sure what that will achieve, it'll just connect you to the router by a wired connection, rather than wireless, it won't cause you to have a static IP address.

Quote:
I'm not trying to get access outside of home - just having problems with iTunes recognising my NAS wirelessly...it will do if imac also connected to the router by ethernet.

It's not a Speedtouch/Thompson router is it?

Streamer's picture
Offline
Joined: 11 Oct 2008
Posts: 87
RE: Problems with setting static IP address

A static IP is pretty easy to configure but you need to make sure that you know the IP address of the router - this is used in both the default gateway and DNS settings on the computer to enable Internet access.

 

Apparently the default IP of your router is 192.168.1.254 and most likely has a subnet mask of 255.255.255.0. So you'll need to configure your computer something like this:

 

IP address: 192.168.1.10

Subnet Mask: 255.255.255.0

Default gateway: 192.168.1.254

DNS server: 192.168.1.254

 

If not using dynamic DNS over the Internet you can then set up a port forward from the WAN port of your router to the IP address configured on the computer (as above). If you open a terminal window once you have entered the configuration above you should be able to type 'ping 192.168.1.254' to check you can 'see' the router and then 'ping www.google.com' to check you have DNS and a connection to the Internet.

 

No need to turn off DHCP on anything.

 

Hope this helps

Chisy1's picture
Offline
Joined: 13 Aug 2008
Posts: 222
RE: Problems with setting static IP address

The_Lhc wrote:

Chisy1 wrote:

Thanks The_LHC.

I will need to try to figure out how to ask the router to do this - might just be easier to get those homeplugs!!

I'm not sure what that will achieve, it'll just connect you to the router by a wired connection, rather than wireless, it won't cause you to have a static IP address.

Quote:
I'm not trying to get access outside of home - just having problems with iTunes recognising my NAS wirelessly...it will do if imac also connected to the router by ethernet.

It's not a Speedtouch/Thompson router is it?

 

The problem with iTunes not listing my NAS as a shared device only happens when when the mac is connecting to my home network wirelessly, when it's connected with a wire the NAS is being listed as a shared device.  It is something to do with "Bonjour" not being broadcast over wifi by my router (or something) and the only way to resolve that is to open the ports for which I need a static IP!   

Chisy1's picture
Offline
Joined: 13 Aug 2008
Posts: 222
RE: Problems with setting static IP address

Streamer wrote:

A static IP is pretty easy to configure but you need to make sure that you know the IP address of the router - this is used in both the default gateway and DNS settings on the computer to enable Internet access.

 

Apparently the default IP of your router is 192.168.1.254 and most likely has a subnet mask of 255.255.255.0. So you'll need to configure your computer something like this:

 

IP address: 192.168.1.10

Subnet Mask: 255.255.255.0

Default gateway: 192.168.1.254

DNS server: 192.168.1.254

 

If not using dynamic DNS over the Internet you can then set up a port forward from the WAN port of your router to the IP address configured on the computer (as above). If you open a terminal window once you have entered the configuration above you should be able to type 'ping 192.168.1.254' to check you can 'see' the router and then 'ping www.google.com' to check you have DNS and a connection to the Internet.

 

No need to turn off DHCP on anything.

 

Hope this helps

 

Thanks, I did this and it didnt work.  Although the only thing different from your note  is that my ISP provided two DNS numbers which were completely different to the router IP address.  In fact they asked me to try two sets of DNS numbers and neither worked.  Shall try the 192.168.1.254 and see what happens

The_Lhc's picture
Online
Joined: 16 Oct 2008
Posts: 12582
RE: Problems with setting static IP address

Chisy1 wrote:

The_Lhc wrote:
It's not a Speedtouch/Thompson router is it?

The problem with iTunes not listing my NAS as a shared device only happens when when the mac is connecting to my home network wirelessly, when it's connected with a wire the NAS is being listed as a shared device.  It is something to do with "Bonjour" not being broadcast over wifi by my router (or something)

Yes that's why I asked what the router is as mine does exactly the same thing (I don't use iTunes or a Mac, my PC can't browse the NAS if I'm connected wirelessly).

Quote:
and the only way to resolve that is to open the ports for which I need a static IP!

Who told you that?

The_Lhc's picture
Online
Joined: 16 Oct 2008
Posts: 12582
RE: Problems with setting static IP address

Chisy1 wrote:
Thanks, I did this and it didnt work.  Although the only thing different from your note  is that my ISP provided two DNS numbers which were completely different to the router IP address.  In fact they asked me to try two sets of DNS numbers and neither worked.  Shall try the 192.168.1.254 and see what happens

Those are your ISPs external DNS servers, if you've got no connection to your router you'll never be able to use them (because they're on the "other" side of your internet connection).

Chisy1's picture
Offline
Joined: 13 Aug 2008
Posts: 222
RE: Problems with setting static IP address

AnotherJoe wrote:

*With port forwarding - if you use the devices network name rather than its ipaddress you dont need static ips.

 

However if you want static ips....

When your routers internet connection is working - on its config page make a note of subnet mask ( probably 255.255.255.0 ) and the DNS Gateway.

 

Turn off DHCP on the router.

Manually add the ip address of the router eg ( 192.168.0.1 ), the subnetmask, and the DNS Gateway from before. Save.

 

Then you can enter static ip addresses for each of your devices on your network - making sure each one is unique. For each device on the network the default gateway is the ip address of the router. subnet mask as above.

 

 

 

I don't follow "*With port forwarding - if you use the devices network name rather than its ip address you dont need static ips." but this is all getting rather complicated. 

The worrying point I've picked up on is that if I turn off DHCP on my router then every device (about 5 of them!) which connect to the internet will all need static IP addresses set up - heart sinks as I end up like help, I`m sinking  

 

And if  a friend pops around and wants to connect to my wifi I'll have to configure a static IP address for them.  This might cause more problems than it solves. 

 

 

 

Chisy1's picture
Offline
Joined: 13 Aug 2008
Posts: 222
RE: Problems with setting static IP address

The_Lhc wrote:

Chisy1 wrote:
Thanks, I did this and it didnt work.  Although the only thing different from your note  is that my ISP provided two DNS numbers which were completely different to the router IP address.  In fact they asked me to try two sets of DNS numbers and neither worked.  Shall try the 192.168.1.254 and see what happens

Those are your ISPs external DNS servers, if you've got no connection to your router you'll never be able to use them (because they're on the "other" side of your internet connection).

 

Okay, that makes sense.  Sorting out home networks is what Friday nights are for...aren't they?

The_Lhc's picture
Online
Joined: 16 Oct 2008
Posts: 12582
RE: Problems with setting static IP address

Chisy1 wrote:

AnotherJoe wrote:

*With port forwarding - if you use the devices network name rather than its ipaddress you dont need static ips.

 

However if you want static ips....

When your routers internet connection is working - on its config page make a note of subnet mask ( probably 255.255.255.0 ) and the DNS Gateway.

 

Turn off DHCP on the router.

Manually add the ip address of the router eg ( 192.168.0.1 ), the subnetmask, and the DNS Gateway from before. Save.

 

Then you can enter static ip addresses for each of your devices on your network - making sure each one is unique. For each device on the network the default gateway is the ip address of the router. subnet mask as above.

 

 

 

I don't follow "*With port forwarding - if you use the devices network name rather than its ip address you dont need static ips." but this is all getting rather complicated. 

The worrying point I've picked up on is that if I turn off DHCP on my router then every device (about 5 of them!) which connect to the internet will all need static IP addresses set up - heart sinks as I end up like help, I`m sinking  

And if  a friend pops around and wants to connect to my wifi I'll have to configure a static IP address for them.  This might cause more problems than it solves. 

That's why I don't think you need to do it. On my router (which is ancient rubbish, frankly), you can see all the connected devices, choose a device and tell the router to fix the IP address for that device, so that, although DHCP is still active (so everything else carries on working fine), those devices you "fix" will always keep the same IP address. That's all you need to do, assuming your router supports that, and I'd be surprised if it didn't. It's probably worth "fixing" the IP address of the NAS as well.

The_Lhc's picture
Online
Joined: 16 Oct 2008
Posts: 12582
RE: Problems with setting static IP address

Chisy1 wrote:

The_Lhc wrote:

Chisy1 wrote:
Thanks, I did this and it didnt work.  Although the only thing different from your note  is that my ISP provided two DNS numbers which were completely different to the router IP address.  In fact they asked me to try two sets of DNS numbers and neither worked.  Shall try the 192.168.1.254 and see what happens

Those are your ISPs external DNS servers, if you've got no connection to your router you'll never be able to use them (because they're on the "other" side of your internet connection).

 

Okay, that makes sense.  Sorting out home networks is what Friday nights are for...aren't they?

Funnily enough tonight I'll be attempting to use a Netgear DGN2000 to extend my wireless network along my house, I just don't know if it'll support that!

Chisy1's picture
Offline
Joined: 13 Aug 2008
Posts: 222
RE: Problems with setting static IP address

[

Quote:
and the only way to resolve that is to open the ports for which I need a static IP!

Who told you that?

[/quote]

 

What I meant to say was that if I open the correct ports on my router that will correct the NAS not being recognised in iTunes and in order for that fix to be permanent the computer has to have a static IP...the first few paragraphs of this page http://portforward.com/english/routers/port_forwarding/Thomson-Alcatel/TG585v8/iChat.htm

 

My router is the Thomson-Alcatel TG585v8 

Streamer's picture
Offline
Joined: 11 Oct 2008
Posts: 87
RE: Problems with setting static IP address

The LHC is correct - your ISP DNS servers will be used by your router using the Internet port whereas your computer will need to use the router as it's 'internal' DNS server.

 

Bonjour uses a protocol called MDNS (Multicast DNS) to discover devices and some wireless routers may either filter/block or just not understand MDNS, thus stopping iTunes from seeing the NAS. It is probably worth you looking on the router itself (enter https://192.168.1.254 in your browser, you might need to Google the username and password) and see if multicast can be enabled anywhere within the settings. 

This page might help with manuals etc: http://www.technicolorbroadbandpartner.com/dsl-modems-gateways/products/product-detail.php?id=161

Port forwarding would be used if you wanted to access a device in your home from another place (like your office) - it can't be applied on the LAN in your case.