202 posts / 0 new
Last post
BIGBERNARDBRESSLAW's picture
Online
Last seen: 10 min 21 sec ago
Joined: 20/10/2010 - 19:33
Posts: 5117
RE:

andybeau wrote:

BIGBERNARDBRESSLAW wrote:

Alears wrote:

Well, did you get it??

I did, offer accepted.  :cheers:

Now I need to work out whether the new cartridge I bought for the RP6 will go with the Concept.

Thanks again Andy for your advice last night.

:bounce: Dance 4

Well done

Well that cartridge you've got, was it the shure or at, should be ok as a start

Yeah, was the Shure M97xE. I guess I'll have to see how I get on with it. 

 

 

BIGBERNARDBRESSLAW's picture
Online
Last seen: 10 min 21 sec ago
Joined: 20/10/2010 - 19:33
Posts: 5117
RE: Rega RP6 missing part and hairline crack

Alears wrote:

Well done. There is no reason the cartridge will not go fine with the new turntable. Enjoy! Smile

It would seem andybeau just pipped me to the post!

Does that mean you were interested in the Concept?

Anonymous
Anonymous's picture
RE: RE:

BIGBERNARDBRESSLAW wrote:

andybeau wrote:

BIGBERNARDBRESSLAW wrote:

Alears wrote:

Well, did you get it??

I did, offer accepted.  :cheers:

Now I need to work out whether the new cartridge I bought for the RP6 will go with the Concept.

Thanks again Andy for your advice last night.

:bounce: Dance 4

Well done

Well that cartridge you've got, was it the shure or at, should be ok as a start

Yeah, was the Shure M97xE. I guess I'll have to see how I get on with it. 

 

 

I've got that on my short list, its cheaper than my elys2(which is a good thing Wink ), but gets good reviews from users all over and 

being used on some great tt's

stevebrock's picture
Offline
Last seen: 11 hours 50 min ago
Joined: 13/11/2009 - 11:16
Posts: 3860
RE: Rega RP6 missing part and hairline crack

glad you got sorted!

 

BIGBERNARDBRESSLAW's picture
Online
Last seen: 10 min 21 sec ago
Joined: 20/10/2010 - 19:33
Posts: 5117
RE: RE:

andybeau wrote:

BIGBERNARDBRESSLAW wrote:

andybeau wrote:

BIGBERNARDBRESSLAW wrote:

Alears wrote:

Well, did you get it??

I did, offer accepted.  :cheers:

Now I need to work out whether the new cartridge I bought for the RP6 will go with the Concept.

Thanks again Andy for your advice last night.

:bounce: Dance 4

Well done

Well that cartridge you've got, was it the shure or at, should be ok as a start

Yeah, was the Shure M97xE. I guess I'll have to see how I get on with it. 

 

 

I've got that on my short list, its cheaper than my elys2(which is a good thing Wink ), but gets good reviews from users all over and 

being used on some great tt's

Someone on here recommended it to me, name escapes me, so apologies to them, but it does seem like an excellent cartridge for the money.

I'm not looking forward to the process of connecting it to the Concept though, but as I said before, I need to learn these things.

 

 

BIGBERNARDBRESSLAW's picture
Online
Last seen: 10 min 21 sec ago
Joined: 20/10/2010 - 19:33
Posts: 5117
RE: Rega RP6 missing part and hairline crack

stevebrock wrote:

glad you got sorted!

 

Thanks Steve, I really hope so anyway. Still no refund from MA though.

Anonymous
Anonymous's picture
RE: RE:

BIGBERNARDBRESSLAW wrote:

 

Someone on here recommended it to me, name escapes me, so apologies to them, but it does seem like an excellent cartridge for the money.

I'm not looking forward to the process of connecting it to the Concept though, but as I said before, I need to learn these things.

 

Its not hard to fit just fiddly fitting. Make sure the wires are all the way home.

Then you need to do the alignment, heres a link to the manual

http://www.clearaudio.de/download/laufwerke/new-generation/concept_de_en.pdf

BIGBERNARDBRESSLAW's picture
Online
Last seen: 10 min 21 sec ago
Joined: 20/10/2010 - 19:33
Posts: 5117
RE: RE:

andybeau wrote:

BIGBERNARDBRESSLAW wrote:

 

Someone on here recommended it to me, name escapes me, so apologies to them, but it does seem like an excellent cartridge for the money.

I'm not looking forward to the process of connecting it to the Concept though, but as I said before, I need to learn these things.

 

Its not hard to fit just fiddly fitting. Make sure the wires are all the way home.

Then you need to do the alignment, heres a link to the manual

http://www.clearaudio.de/download/laufwerke/new-generation/concept_de_en.pdf

Good man, thanks

mitch65's picture
Offline
Last seen: 1 day 3 hours ago
Joined: 16/12/2003 - 12:50
Posts: 1153
RE: RE:

Nice one BBB.

They say bad things happen for a reason - to make way for better things.

Who wants a poxy Rega anyway ROFL

Hi-FiOutlaw's picture
Offline
Last seen: 21 hours 39 min ago
Joined: 20/04/2011 - 23:03
Posts: 2008
RE: Rega RP6 missing part and hairline crack

CONGRATS!!!! TWICE. :cheer: :cheer: :cheer:

BIGBERNARDBRESSLAW's picture
Online
Last seen: 10 min 21 sec ago
Joined: 20/10/2010 - 19:33
Posts: 5117
RE: RE:

mitch65 wrote:

Nice one BBB.

They say bad things happen for a reason - to make way for better things.

Who wants a poxy Rega anyway ROFL

Well, not me. But I would quite like a refund on a Rega though.  :)

BIGBERNARDBRESSLAW's picture
Online
Last seen: 10 min 21 sec ago
Joined: 20/10/2010 - 19:33
Posts: 5117
RE: RE:

No Concept yet, and still no refund from MA. Not good enough seeing as they've had the turntable back a week now. 

stevebrock's picture
Offline
Last seen: 11 hours 50 min ago
Joined: 13/11/2009 - 11:16
Posts: 3860
RE: Rega RP6 missing part and hairline crack

have you actually spoken to MA

BIGBERNARDBRESSLAW's picture
Online
Last seen: 10 min 21 sec ago
Joined: 20/10/2010 - 19:33
Posts: 5117
RE: Rega RP6 missing part and hairline crack

Well, they've replied to my email from this luchtime, and they claim that the refund was issued this morning, but it's not showing up on my online banking.

Maybe these things take a few days to process, I'm not sure, I'll check again on Monday.

stevebrock's picture
Offline
Last seen: 11 hours 50 min ago
Joined: 13/11/2009 - 11:16
Posts: 3860
RE: Rega RP6 missing part and hairline crack

BIGBERNARDBRESSLAW wrote:

Well, they've replied to my email from this luchtime, and they claim that the refund was issued this morning, but it's not showing up on my online banking.

Maybe these things take a few days to process, I'm not sure, I'll check again on Monday.

i guess it will show up Mon/Tues then - what a crap experience you have had!

 

Pages

Log in or register to post comments