16 posts / 0 new
Last post
tobythetenor's picture
Last seen: 1 month 2 weeks ago
Joined: 13/01/2014 - 16:14
Posts: 4
Airplay broken on Marantz M-CR603

Hi all,

I bought a Marantz M-CR603 in October 2013 (great deal!).
Initially, I did not have the Airplay upgrade, so I signed up and it was delivered.

It worked perfectly fine until I received an "upgrade notification" about 14 days ago.
I upgraded, and ever since, when I try to stream via Airplay, it connects briefly, sets the Volume to 50, then drops and the display shows "(list empty)".

Has anybody else experienced that, and (ideally) has a solution?

I contacted the Marantz support. They pointed out that no upgrade had been released for this model since 2012 (I believe that, but I only bought it recently, so it may not have been up-to-date), and they further seem to think that it's a problem with my set-up.
I have tried a number of steps as advised by Marantz: 

- reset to factory default by power-cycling and pressing Volume up + Stop (says Factory Reset)
- reset the microprocessor by power cycling and pressing Volume up + Volume Down (says Initializing)
- replaced my D-Link (DIR-615) router with a Netgear model I had
- (temporarily) opened ports 3813, 443, 80, 8080, 3689 TCP, 554, 5353 UDP on my router (should not be necessary to open WAN ports for LAN communication)
- I have tried unplugging all other networked devices (particularly airplay ones)
- I have exchanged the network cable for one I'm sure is working without fault.
- I have tried both DHCP and static configuration.

Please note that:

- The iMac I am trying from and the Marantz are both directly plugged into the router (i.e. there is no wireless involved)
- streaming from my iPad wireless does also not work to the MCR603
- Playing music from my local music server works perfectly fine, so I think we can assume that the connection as such is ok.
- Airplay works fine on the two other Airplay devices in the house, which are a Apple TV and a Raspberry Pi (running Open Elec).
- Have a friend who own a Pioneer X-HM81-K, which he brought round this morning. We plugged it in to the same connection where the M-CR603 normally lives, and Airplay worked fine.

I noticed that every(!) time I power on the device (from standby) the display now says:

- Setup for starting...
-- 1/4 Initialize...
-- 2/4 Connecting
-- 3/4 Checking Info
-- 4/4 Waiting Reply...

I did not see this behaviour before on a regular basis.

The scenario is always the same. The MCR603 shows as Airplay device. I then select it. It will play for about one second, then the connection drops. The MCR603 displays "(list empty)".

I have uploaded a video showing what happens, please PM me for the link.

I've copied in output from the Apple Console underneath. The message that stands out is the 61/0x3D ECONNREFUSED

I guess that the firmware upgrade went wrong, but Marantz does not believe me.

Below the excerpt from the Apple Console with the error messages.

10/01/2014 08:08:12.917 SystemUIServer[240]: 2014-01-10 08:08:12.916750 AM [AirPlayAVSys] Picking route 'MZ' (00:06:78:09:0A:F6)
10/01/2014 08:08:12.918 SystemUIServer[240]: 2014-01-10 08:08:12.917813 AM [AirPlayAVSys] Selecting endpoint 00:06:78:09:0A:F6, item 39 for (audio only)
10/01/2014 08:08:12.918 coreaudiod[159]: 2014-01-10 08:08:12.918456 AM [AirPlay] Selecting endpoint 00:06:78:09:0A:F6 "MZ" for A/V
10/01/2014 08:08:12.934 AirPlayUIAgent[16703]: 2014-01-10 08:08:12.933930 AM [AirPlayAVSys] AirPlay became the default audio device
10/01/2014 08:08:12.934 SystemUIServer[240]: 2014-01-10 08:08:12.934100 AM [AirPlayAVSys] AirPlay became the default audio device
10/01/2014 08:08:17.987 coreaudiod[159]: 2014-01-10 08:08:17.986678 AM [AirPlay] ### Audio send error: 61/0x3D ECONNREFUSED
10/01/2014 08:08:18.168 coreaudiod[159]: 2014-01-10 08:08:18.167752 AM [AirPlay] ### Endpoint "MZ" keep-alive error: -6753/0xFFFFE59F kConnectionErr
10/01/2014 08:08:18.168 coreaudiod[159]: 2014-01-10 08:08:18.167873 AM [AirPlay] ### Error with endpoint "MZ": -6753/0xFFFFE59F kConnectionErr
10/01/2014 08:08:18.168 coreaudiod[159]: 2014-01-10 08:08:18.167996 AM [BonjourBrowser] Reconfirming PTR for 000678090AF6@MZ._raop._tcp.local. on en0
10/01/2014 08:08:18.168 coreaudiod[159]: 2014-01-10 08:08:18.168247 AM [AirPlay] Quiescing endpoint 'MZ'
10/01/2014 08:08:18.168 SystemUIServer[240]: 2014-01-10 08:08:18.168472 AM [AirPlayAVSys] ### Quiesce AirPlay
10/01/2014 08:08:18.169 AirPlayUIAgent[16703]: 2014-01-10 08:08:18.168498 AM [AirPlayAVSys] ### Quiesce AirPlay
10/01/2014 08:08:18.176 coreaudiod[159]: 2014-01-10 08:08:18.175668 AM [AirPlay] ### Endpoint "MZ" auth-setup error: 200453/0x30F05 Not Enough Bandwidth
10/01/2014 08:08:18.176 coreaudiod[159]: 2014-01-10 08:08:18.175759 AM [AirPlay] ### MFi failed: 200453/0x30F05 Not Enough Bandwidth
10/01/2014 08:08:18.176 coreaudiod[159]: 2014-01-10 08:08:18.175854 AM [AirPlay] ### Endpoint "MZ" start failed: 200453/0x30F05 Not Enough Bandwidth
10/01/2014 08:08:18.176 coreaudiod[159]: 2014-01-10 08:08:18.175968 AM [AirPlay] Posted 'com.apple.AirTunes.endpointStartError' with 200453/0x30F05 Not Enough Bandwidth
10/01/2014 08:08:18.176 coreaudiod[159]: 2014-01-10 08:08:18.176101 AM [AirPlay] Posting kAudioDevicePropertyDataSourceInfoForID: item 39 error: 200453/0x30F05 Not Enough Bandwidth
10/01/2014 08:08:18.185 SystemUIServer[240]: 2014-01-10 08:08:18.185339 AM [AirPlayAVSys] AirPlay no longer the default audio device
10/01/2014 08:08:18.185 AirPlayUIAgent[16703]: 2014-01-10 08:08:18.185372 AM [AirPlayAVSys] AirPlay no longer the default audio device
10/01/2014 08:08:18.188 coreaudiod[159]: 2014-01-10 08:08:18.188108 AM [AirPlay] ### Write audio (2048 bytes) when client not fully started


I'd be very grateful if anybody has any hints / tips / tricks what to do. Airplay was the main feature that made me buy this Receiver, and without it it's lost half its use.

Many thanks in advance for the help!

morghini's picture
Last seen: 2 years 3 months ago
Joined: 14/09/2004 - 13:04
Posts: 2
RE: Airplay broken on Marantz M-CR603

Sorry I can't help, wish I could.  I only stumbled across this post as I was having a problem with my Marantz MCR603 connecting to Spotify (on a laptop) via Airfoil.  It turns out the problem was my new Netgear router, for some reason it wont allow Airplay to see the Marantz, however when I used my 8 year old Belkin router again :  Airplay can see my Marantz straight away & works perfectly.

Perhaps its some ports that I need to open up as you suggest in your post

Good luck!

kilmanaj's picture
Last seen: 1 year 7 months ago
Joined: 17/03/2014 - 20:43
Posts: 2
RE: Airplay broken on Marantz M-CR603

I am seeing the same issue here and am also going through the hoops. Also got an update notification in ~ September? Airplay has not correctly ever since. 

Next option for me is to:

Create a small network between the router, the mac and the MCR-603, see if it works. 



For morghini

If you are having difficulties listing the device in the airplay option/sound option on mac - the issue could be on the router: try to see if you can disable multicast on the router itself. I had this issue moving to a new place with a BT home hub like device. Disabling multi-cast worked - but broke the TV signal - had to isolate the network for the TV for it to work. 



clanger9's picture
Last seen: 1 year 5 months ago
Joined: 17/09/2011 - 14:06
Posts: 2
RE: Airplay broken on Marantz M-CR603

I have exactly the same problem: connects OK, sets the volume, plays 1/2 second of audio then drops and the display shows "(list empty)"

This unit has been in the loft for a few months, but was working perfectly. Now it doesn't.

I've tried Factory Reset  (Volume up + Stop) and Initialize (Volume up + Volume Down) as recommended by Marantz tech support. No difference  :cry:

Routers are all Apple, my network is rock solid and everything is up to date. It's the same whether streaming from a phone or a computer, so my guess is that it's the Marantz that's faulty. Airplay also works fine to other gear around the house.


Any ideas?


I've temorarily rigged up an Aiport Express to stream though the optical input (which works fine), but I'd like to have my built-in Airplay feature back!

ozzy_2014's picture
Last seen: 2 years 2 months ago
Joined: 22/05/2014 - 21:25
Posts: 1
RE: Airplay broken on Marantz M-CR603

Has anyone made any progress on this issue?  I now have exactly the same issue. I have contacted Marantz support but they have just suggested doing a factory reset which hasnt resolved the problem.

I can airplay to apple TV fine over same network, and I can play music from my NAS on the CR603 so my network seems OK.  I have also tried an older version of Itunes (10.7)  but that had the same issue.



rushie's picture
Last seen: 2 years 1 month ago
Joined: 29/05/2014 - 11:04
Posts: 1
RE: Airplay broken on Marantz M-CR603

I have had the exact same issue recently. Everything was working ok then one day Airplay would drop out after a second or so and default to Music Server "List Empty" with the volume at 50.

I could stream music directly via DLNA from my home server all day long but not via Airplay from any device. I tried factory resetting / initializing the Marantz, rebooting the network router but no luck. 

My Marantz was set to get its IP settings via DHCP from my router. I discovered the trick for me to get my Airplay working again was to turn DHCP OFF on the Marantz netwrok settings and manually entered a NEW and different IP address to what it was getting via DHCP and just put in an IP address, subnet and gateway address - no DNS or proxy etc,.... 

Maybe forcing DHCP to allocate a different IP address to the Marantz MAC might work also - I didnt try this.

I hope it keeps working ok fingers crossed!

IainS's picture
Last seen: 5 months 2 weeks ago
Joined: 02/12/2011 - 15:02
Posts: 11
PC issue

I had this problem until I happened to switch off my Laptop and all worked fine. What you must do is check the media settings on all attached PCs and laptops to ensure that the 603 or 7004 device is permitted to access media files, even if that computer has no media files you use. After I did this all worked fine. How you do this depends on the OS version.


hope this helps.

tobythetenor's picture
Last seen: 1 month 2 weeks ago
Joined: 13/01/2014 - 16:14
Posts: 4
Hi all - sorry for not

Hi all - sorry for not replying for such a long time.

The MCR603 went back to the dealer, who sent a replacement instead of having it fixed.
I experienced the same problem with the replacement, so I ultimately returned it and bought an MCR610 instead.
The MCR610 works flawlessly!

I don't know what the issue is, but from this forum I gather I'm not the only one who experiences this problem.

Marantz support unfortunately were very unhelpful in this matter, there is not even so much as an acknowledgement that this is actually a problem.

Peter Van Hende's picture
Last seen: 1 year 8 months ago
Joined: 09/11/2014 - 16:52
Posts: 1
Linked to my WD MyCloud NAS


I had the exact same problem. I didn't solve it yet, but I found the cause.

There seems to be a conflict with my new WD MyCloud NAS. When Idisconnect the NAS from my network (or if I disable the DLNA server on the NAS) my Airplay works fine again on my Marantz.

I found some people on the WD support forum that have the same problem. No solution yet (apart from disabling the DLNA on the NAS, which is not ideal). http://community.wd.com/t5/WD-My-Cloud/Dlna-server-conflict-with-airplay/td-p/662967


kilmanaj's picture
Last seen: 1 year 7 months ago
Joined: 17/03/2014 - 20:43
Posts: 2
Resolution - well, at least for me

Hi - big apologies to everyone for the delays in me investigating this - work and personal life took over and did not had the leisure of time to setup a tiny lab to test this out. 

Problem I had was - Marantz MCR 603 would list on airplay speaker selection screen but once selected would play ~ 1 second. 

Issue - Multicast forwarding in certain conditions. 

All my network equipment is connected directly to a central switch ( SG200-26 Cisco).
Problem occured only in between Apple TV3 and Marantz - airport express worked perfectly. 

On the test bed network (this switch but factory reset) with no apple TV the amp worked flawlessly via Airplay. 
Inserting apple TV3 on the network - still working
Starting up apple TV3 - still working
Starting an airplay session - Marantz would start behaving again and only factory reset (probably a simpler more elegant solution exists but this wasn't the point of the excercise. 



I've put all ports (only 1 vlan for now) to static. 
Marantz for now seems to be working like a charm over airplay. (only been a day -but better than any other attempts so far). 



mugam's picture
Last seen: 5 months 3 weeks ago
Joined: 04/09/2013 - 12:03
Posts: 7
No solution yet

I also am facing the same problem  and symptoms.


Marantz M-CR603/ASUS Laptop (Windowds 7 HB)/WD My CLOUD 4TB/Zyxel Keenetic Giga II, Dune HD mediaplayer

Airplay mode doesn't work, when I start iTunes on ASUS laptop. Airplay starts for a second. Then on Marantz display appears "list empty" an it stops.  When WD My Cloud is off, when DLNA server (Twonky) in WD My Cloud is off, or when Marantz is connected directly to the laptop everything works perfectly. I've tried DHCP, static IP, both RESETS of Marantz - all in vain. Trying to start My Cloud when Marantz is playing in Airplay mode from laptop, it doesn't connect to the router and network. NAS connects only when Airplay is stopped. 

I wonder what is this "list empty"? Maybe finding this out it would be possible to trace the problem?

When I substitute My Cloud with older WD MyBookLive the are no problems. Airplay works smoothly.

In mediaserver mode Marantz works without problems. Though this "list empty" appears before it enters "mediaserver" mode. It appears even in USB flash, but plays. There are no any "list empty" on WD MBL. Either Airplay, or Mediaserver or USB.

I am an ordinary PC user. I may only suggest that there is some conflict between Airplay and Twonky mediaserver. I don't want to risk and ireplace Twonky by another mediaserver on My Cloud iin order to check whether it  is the reason.  




XMB's picture
Last seen: 10 months 4 weeks ago
Joined: 13/06/2009 - 20:49
Posts: 16
Confirmed WD MyCloud Issue

I found this post after recently installing a WD MyCloud EX2 and am disheartened to see the issue has yet to be resolved by either Marantz or WD. 

Clearly as the issue does not affect the newer CR610 so Marantz must have updated the Airplay firmware, which seems resolves this issue but clearly don't want the cost of adapting it for the older hardware. Shame on them. 

WD may also be partly to blame as it seems it may be partly created by their implementation of the Twonky media server software.

enricosampo's picture
Last seen: 9 months 3 weeks ago
Joined: 05/10/2015 - 19:51
Posts: 1
Airplay issue with Denon RCD - N7 and WD MyCloud

Guys, after playing a bit with this, I think I found something that works without having to deactivate DLNA on MyCloud. I deactivated the "Restart on NIC changes" option on the Twonky Server running on MyCloud. It is in Settings -> Advanced, please check on the web how to access the Server page. It all seems ok now, let's hope it keeps working! 




tabiro's picture
Last seen: 6 months 3 days ago
Joined: 22/01/2016 - 15:21
Posts: 1
Any updates?

I'm considering buying a WD my cloud to store my music library. I want to be able to pull contents from any device, PC, phone or tablet in my network and push it into my Denon AVR1912 via Airplay.

Did your workaround kept on working? It is the only issue keeping me from getting the WD my cloud.


mugam's picture
Last seen: 5 months 3 weeks ago
Joined: 04/09/2013 - 12:03
Posts: 7
Airplay issue with Denon RCD - N7 and WD MyCloud

Thank you enricosampo for sharing your experience.

I've tried your solution with my Marantz-603. Unfortunately no results. Starts playing only for 4 seconds then stops. MyCloud updated with the latest firmware. Windows 10 and the latest iTunes on laptop. Maybe we should contact someone in Marantz Europe with this problem and show them this forum discussion and other on the same issue on WD Community.

MajorFubar's picture
Last seen: 14 hours 7 min ago
Joined: 03/03/2010 - 00:01
Posts: 5361
mugam wrote: Maybe we should

mugam wrote:
Maybe we should contact someone in Marantz Europe with this problem and show them this forum discussion and other on the same issue on WD Community.

I have no positive or negative experience with Marantz but I wouldn't be surprised if you just hit a brick wall there. But I'm happy to be proved wrong. The 603 is two generations out of date, though young enough for you to have every right to expect it still to work as described. If they brushed you off you may have to go through trading standards.

Thorens TD160+Ortofon MC3; Mission PCM II CD; HRT II+ DAC and Mac Mini; Modded Cyrus 2+PSX; Cyrus Tuner mk2; EB2 loudspeakers

Log in or register to post comments