6 posts / 0 new
Last post
psurquhart's picture
Offline
Last seen: 3 months 2 weeks ago
Joined: 15/11/2010 - 13:49
Posts: 598
Pure One and Pure Evoke 2-XT Problems Any advice ?

Hi, couple of questions ?

1. Have been given the mother in laws broken Pure One radio. When you turn it on the whole led display flashes and I cant get it to work at all. Has anyone else encountered this problem and is their any easy fix ? Was wondering if their was a master reset procedure to do or shall I just bin it as it would be too costly to send away for repair ?

2. I own the excellent Pure Evoke 2 xt. I use it all the time via the mains ( its constantly plugged in ) but also portably using the chargepak ( cr-6 I think ) battery. It has served me well for ages now but all of a sudden wont hold a charge for long using the chargepak battery. I did try the chargepak from the above Pure One but have the same problem. Would this be the fact that the chargepaks are now old ( prob 5 years old at least ) and need replacing or will i be wasting my money getting a replacement battery ? Could it be the Evoke is faulty and not charging properly ( the re-charge battery display still lights up ) ?

Anyone else had similar problems or can advise ? 

Sizzers's picture
Offline
Last seen: 4 months 3 weeks ago
Joined: 20/06/2008 - 07:15
Posts: 1453
Re: Pure One and Pure Evoke 2-XT Problems Any advice ?

I can't help with your first query but I can with your second.

All rechargeable batteries have a finite life and when they "go" there ability to hold a charge falls off dramatically, seemingly from nowhere. Although modern li-ion batteries can be recharged hundreds of times, eventually they take longer to charge and hold that charge even less so yes, you need a new battery.

psurquhart's picture
Offline
Last seen: 3 months 2 weeks ago
Joined: 15/11/2010 - 13:49
Posts: 598
Re: Pure One and Pure Evoke 2-XT Problems Any advice ?

At last Smile


Was beginning to lose faith in the What Hi Fi posters then ! Its been a while, thanks Sizzers.


Thanks for answering half the post, if you are right then Im well chuffed because I thought I might need a new Pure DAB unit for a moment then - will buy one soon and let you all know the outcome.


Anyone technical for the first question out there ?


Was hoping someone from What Hi Fi might have some input ? 

wrongsideof40's picture
Offline
Last seen: 4 months 6 days ago
Joined: 18/03/2014 - 16:56
Posts: 3
RE: Pure One and Pure Evoke 2-XT Problems Any advice ?

Long story short: Try an alternative power supply. After months of the radio becoming more flakey and, eventually, not working at all, I bit the bullet and did some poking around. The power supply showed 6volts on the multimeter (correct) but on closer investigation, this collapses down to under 3 volts as the radio was going through its initialzation .

The_Lhc's picture
Offline
Last seen: 2 hours 57 min ago
Joined: 16/10/2008 - 13:23
Posts: 12874
RE: Pure One and Pure Evoke 2-XT Problems Any advice ?

wrongsideof40 wrote:

Long story short: Try an alternative power supply. After months of the radio becoming more flakey and, eventually, not working at all, I bit the bullet and did some poking around. The power supply showed 6volts on the multimeter (correct) but on closer investigation, this collapses down to under 3 volts as the radio was going through its initialzation .

You might wish to check the age of a thread before bothering to reply to it, if he hasn't fixed his problem in three years I don't imagine he's still got the device in question...

wrongsideof40's picture
Offline
Last seen: 4 months 6 days ago
Joined: 18/03/2014 - 16:56
Posts: 3
RE: Pure One and Pure Evoke 2-XT Problems Any advice ?

Quite so.  I was aware of the age of the thread.. Just thought it might be useful for others in the future  with a similar fault, who might stumble across this possible solution.

Log in or register to post comments