2 posts / 0 new
Last post
thecrowe's picture
Offline
Last seen: 1 year 7 months ago
Joined: 24/04/2013 - 18:36
Posts: 2
Bizarre pre-amp / DAC issue
English

I recently got hold of an old set of Exposure equipment: VII preamp, 2x VI power supplies and a VIII amp, and an HRT Music Streamer II. Now imagine my disappointment when I one speaker is much quieter than the other and distorted! Furthermore I can't track it the problem down to one bit of the chain: the HRT straight into the amp comes out balanced, and so does any other input through the preamp then amp. Is this a power/grounding issue between the HRT and preamp? The preamp is the dual power model, with one DC input from each power supply. Switching left and right outputs on the DAC doesn't change the bad speaker, but switching pre-amp output does so I know it's always the same preamp channel coming out bad. Any help or pointers would be great! :?

Overdose's picture
Offline
Last seen: 2 days 6 hours ago
Joined: 08/02/2008 - 18:23
Posts: 3673
RE: Bizarre pre-amp / DAC issue

thecrowe wrote:

I recently got hold of an old set of Exposure equipment: VII preamp, 2x VI power supplies and a VIII amp, and an HRT Music Streamer II. Now imagine my disappointment when I one speaker is much quieter than the other and distorted! Furthermore I can't track it the problem down to one bit of the chain: the HRT straight into the amp comes out balanced, and so does any other input through the preamp then amp. Is this a power/grounding issue between the HRT and preamp? The preamp is the dual power model, with one DC input from each power supply. Switching left and right outputs on the DAC doesn't change the bad speaker, but switching pre-amp output does so I know it's always the same preamp channel coming out bad. Any help or pointers would be great! :?

Maybe the preamp needs to be rebiased?

It certainly sounds like it needs a service and a closer look at.

Log in or register to post comments