5 posts / 0 new
Last post
admin's picture
Offline
Last seen: 8 hours 8 min ago
Joined: 04/09/2013 - 14:19
Posts: 51595
Yamaha RXV-667 and Xbox 360 HDMI problem

Hi all, searched on google and can't find any forums on this problem so here goes:

I used to have an old 1st generation Xbox connected to the receiver via component cables and it worked fine. Today I got a new Xbox with a HDMI output but when I connect it to the receiver via HDMI I get a 'no signal' screen on the TV. I can't even bring up the reciever menu on screen. I can hear Xbox sound through the receiver's connected speakers.

If I connect to the receiver via the yellow, red and white cables all works fine but it is obviously low def. If I connect the Xbox via HDMI directly to the TV it works fine in HD but I don't want the extra cable dangling down.

My thinking is that it must be a synching problem with the receiver/xbox via HDMI. I have tried it on HDMI inputs 3, 4 and 5 but no joy. The inputs themselves do work as i've checked them with my freesat box.

Ideally, I would like it to work via HDMI so has anyone got any suggestions? I can't see any switches that I need to move etc.

Many thanks in advance

laserman16's picture
Offline
Last seen: 3 weeks 2 days ago
Joined: 23/11/2007 - 18:17
Posts: 2258
RE: Yamaha RXV-667 and Xbox 360 HDMI problem

Have you tried the HDMI socket on the front?

chris hollands's picture
Offline
Last seen: 3 months 2 weeks ago
Joined: 27/04/2010 - 16:01
Posts: 383
RE: Yamaha RXV-667 and Xbox 360 HDMI problem

Just a thought , you may need to adjust your screen resolution ? 

simonlewis's picture
Offline
Last seen: 1 day 11 hours ago
Joined: 15/04/2008 - 10:17
Posts: 3418
RE: Yamaha RXV-667 and Xbox 360 HDMI problem

I presume you have assigned the HDMI input on your amp.

Anonymous
Anonymous's picture
RE: Yamaha RXV-667 and Xbox 360 HDMI problem

I'm not sure to be honest. Any other time I have used HDMI its been like a plug and play thing. How would i assign? Thanks

Log in or register to post comments