Have your say & ask the experts!

Yamaha RX-V673 - No Signal HDMI Output & the red HDMI indication keep blinking

4 replies [Last post]
m_zaqki's picture
Offline
Joined: 15 Jan 2013
Posts: 2
__________________

m_zaqki's picture
Offline
Joined: 15 Jan 2013
Posts: 2
RE: Yamaha RX-V673 - No Signal HDMI Output

I am currently using Yamaha RX-V673. I have been using this machine for 6 months now and I am very happy with it. It deliveres fantastic sound!!! However, last night after i reached home and tried to watch TV (cable TV), unfortunately, I can only hear the sound but no video. The TV showing "NO SIGNAL" and I started to panic. Then I switched to other sources, PS3, Blue-Ray Player and it is still the same, No Signal. Then I noticed the HDMI output light indicator keep on blinking. Could someone really help me to solve this problem.

__________________

Petherick's picture
Offline
Joined: 29 Oct 2008
Posts: 452
RE: Yamaha RX-V673 - No Signal HDMI Output

Have you checked that the TV is set to the correct input?

__________________

 

f1only's picture
Offline
Joined: 7 Apr 2010
Posts: 1061
RE: Yamaha RX-V673 - No Signal HDMI Output

Have you tried checking that the HDMI's are pushed in properly at both ends from the TV to the amp & the other bits of kit? Mine came loose & i got no picture from just moving the amp slightly when giving it a clean.

 

 

Regards ..

__________________

TV: Sony KDL-46HX853 ( calibrated ), Virgin Tivo Box, BD Players: Sony BDP-S790,  PS3, PS4 & Panasonic DMR-BWT700

A/V Amp: Yamaha RX-V1073

Speakers: Dali Ikon 6 Front L/R, Dali Ikon 1's Surround, Dali Ikon Vocal 2 Centre, B&W ASW610 Subwoofer.

My System

Sony Bravia 46HX853 Calibrated Settings

Weaveta's picture
Offline
Joined: 23 Feb 2013
Posts: 1
RE: Yamaha RX-V673 - No Signal HDMI Output

Any luck on this issue? I have the same problem.

 

Thanks