2 posts / 0 new
Last post
admin's picture
Online
Last seen: 19 hours 13 min ago
Joined: 04/09/2013 - 14:19
Posts: 51601
Yamaha 2067 - No Video
English

Hi everyone,

I've been using my Yamaha 2067 happily since April this year but today, after some extensive rewiring it won't output a video signal. I use my 2067 as a hub for my bluray, PS3 and Western Digital Media Player which worked perfectly until today. I've just tested the HDMI cable using the WD player and it works fine so I know that the fault must be with the receiver.

Has anyone experienced similar problems? I can't see how this would fail so quickly. I've plugged and unplugged the cable from the receiver and television in the hope that it was some sort of handshake issue but this hasn't solved the problem at all.

Is there anything else I can try?

f1only's picture
Offline
Last seen: 1 day 20 hours ago
Joined: 07/04/2010 - 09:14
Posts: 1062
RE: AV receivers

Has it got the latest firmware update on it? version 3.16 found here. It does say check the units firmware 1st prior to update.

I would try this 1st though, according to the manual page 134.    Displays in the Advanced Setup Menu & select " VIDEO" in "INITIALIZE" to reset the video paramaters & then Displays in the Advance Setup menu & set "MONITOR CHECK" to "YES". As the amp has 2 hdmi outs i would check them both.

If you have'nt got the manual on disc you can download it here as a pdf, click support on the tabs to access.

Hope that's some assistance.

Regards...

 

Speakers - Dali Ikon 6 F L/R, Ikon Vocal 2 MK2 Centre, Ikon 1 Surround, B&W 610 Subwoofer. TV - Calibrated Sony 46" HX853. BDP - Sony mr BDPS790, PS3, PS4. A/V Amp - Yamaha RXV 1073

Log in or register to post comments