5 posts / 0 new
Last post
admin's picture
Offline
Last seen: 1 day 2 hours ago
Joined: 04/09/2013 - 14:19
Posts: 51595
subwoofer sound problem please help

Hi iam new to this forum iam not shure if iy should be in blue ray section or here but thought i would start here i have a denon avr2311 setup as 7.1 samsung bdp4600 blueray, sony subwoofer and this is were my problem is it plays music perfect through a sony cd mega discplayer movies play perfect through my virgin hd box but a soon as i play a movie blueray or other format through the samsung bdp4600 my sub sounds terrible i have tried every setting in the samsung setup audio,changed the hdmi lead for a expensive to a cheap lead no difference,and changed my av[had a sony 5.1 and thought the amp was faulty so changed it,and had the sound run through a digital optical cable and it makes the same disstorted sound on what should be deep booming sounds] so iam at a loss been tring to sort this for 2 months any help ect will be gratfully recieved

Anonymous
Anonymous's picture
RE: subwoofer sound problem please help

What sort of Subwoofer is it? Is it an active sub or a passive sub that was once part of a 5.1 all-in-one system?

Go into your AVR setup menu>>speakers>>level/crossover settings. What do you have the subwoofer crossover set at?

Anonymous
Anonymous's picture
RE: subwoofer sound problem please help

hi its a sa-wm20 active sub it was part of a 5.1 setup but had same sound problem, one of the reason i changed it [also liked the sound of the denon] as for crossover setting if i go into auto setup parameter check crossover check it does not list the sub! but in channel level check it is set at -10.0db i set it up using the auto setup

Anonymous
Anonymous's picture
RE: subwoofer sound problem please help

thanks for the help

Anonymous
Anonymous's picture
RE: subwoofer sound problem please help

SORTED BOUGHT NEW SUB NOW PERFECT

Log in or register to post comments