4 posts / 0 new
Last post
simonlewis's picture
Offline
Last seen: 3 days 20 hours ago
Joined: 15/04/2008 - 10:17
Posts: 3554
failing onkyo 606
English

My onkyo 606 on screen display died a while back & now i can't run my blu-ray player through the amp because i get error code U73 on the blu-ray player, it works straight into the tv, so now i'm not sure what to do.

I've just phoned genserve about repair & they said it would be about £100 before parts, £30 for transport their & back & £70 just to look at it.

So not sure weather to take it down the tip & get a new one or get it repaired.:(

Big Aura's picture
Offline
Last seen: 4 days 12 hours ago
Joined: 13/10/2008 - 19:38
Posts: 2460
RE: failing onkyo 606

Sorry to hear that.  Unfortunately, I doubt they'll guarantee to fix it for that either...  It might be worthwhile upgrading (look at last year's models - Denon 2311s are decent money), or go to eBay and see what's available second hand and working.  You may be able to sell yours for spares?

Ravey Gravey Davy's picture
Offline
Last seen: 1 month 1 day ago
Joined: 28/04/2008 - 16:47
Posts: 2680
RE: failing onkyo 606

Always worth seeing if this is actually of use to you.Can't see you getting above £50 anyway in that condition

simonlewis's picture
Offline
Last seen: 3 days 20 hours ago
Joined: 15/04/2008 - 10:17
Posts: 3554
RE: failing onkyo 606

I got the amp repaired at a cost of £117, i'm a bit reluctant to put it back in the rack though as it's only 7 1/2" high, so not sure what to do i can either wall mount the tv leaving space on the top shelf for the amp, which i don't want to do as it;s rented accomodation or i can get a new rack, i would like a solid oak one built to order but that will be expensive.

Log in or register to post comments