4 posts / 0 new
Last post
goalhanger's picture
Offline
Last seen: 3 months 1 day ago
Joined: 11/01/2011 - 10:52
Posts: 90
BA Sub stopped working
English

My BA sub has decided not to work all of a sudden. No sound from any inputs including B/Ray which is optical lead to amp. Tried all the normal settings on the amp ( Yamaha RX-V667)  to no avail. All the lights work on the sub , but when turning on TV/music the light stays red so is not picking up a signal to activate.

Any other checks I can try short of a new sub or amp ?

Ta

Panasonic TH 42PZ70B, Yamaha RX-V667, Boston Acoustics XS 5.1, Sony BDP S360, TiVo

Marantz PM6300, Technics SL-B2+Ortophon VMS20E, Phillips CD, Rega RS5 + Rega cable, Grado SR80i h/phones.

 

ellisdj's picture
Online
Last seen: 2 hours 43 min ago
Joined: 11/12/2008 - 17:55
Posts: 1511
What sub is it please - full

What sub is it please - full model number?

Meridian 861 V4 LPSU, HD621, Bryston 9BSST - GIK Acoustics

Monitor Audio PL100, PLC 150, GXFX, SVS SB13 ULTRA

Audio PC LPSU + Batts, JPLAY, JCAT and PPA Studio

65VT65, UD7007, Graham Slee Cables, Isotek, XLO,

goalhanger's picture
Offline
Last seen: 3 months 1 day ago
Joined: 11/01/2011 - 10:52
Posts: 90
Hi, Its the one that came

Hi, Its the one that came with the BA XS 5.1 system, a couple of years ago, so not the latest version. But I have just remembered I have 2 sub outputs on the Yamaha so I gonna go home and try it in the other one , cant see very well at the back so I missed it last night. Not too pleased with the Yamaha reliability as it also wont play the Tivo through number 1 input but everything else works through it. It did initially work ok .

Will report back tomorrow , fingers crossed it will work in output 2 .

Phil

Panasonic TH 42PZ70B, Yamaha RX-V667, Boston Acoustics XS 5.1, Sony BDP S360, TiVo

Marantz PM6300, Technics SL-B2+Ortophon VMS20E, Phillips CD, Rega RS5 + Rega cable, Grado SR80i h/phones.

 

goalhanger's picture
Offline
Last seen: 3 months 1 day ago
Joined: 11/01/2011 - 10:52
Posts: 90
Hi, I just looked and I only

Hi, I just looked and I only have 1 sub output .....but I have other pre-out outputs so as the sub is active I have presumed it's ok to plug into this . And hey presto it works . I am also presuming this is ok for the amp. Bit annoyed with amp though. I might check if I bought any extra warranty with it from Richers.

 

Panasonic TH 42PZ70B, Yamaha RX-V667, Boston Acoustics XS 5.1, Sony BDP S360, TiVo

Marantz PM6300, Technics SL-B2+Ortophon VMS20E, Phillips CD, Rega RS5 + Rega cable, Grado SR80i h/phones.

 

Log in or register to post comments